رتبه موضوع:
  • 1 رای - 5 میانگین
  • 1
  • 2
  • 3
  • 4
  • 5
لود نشدن کتابخانه inflector
#1
سلام. مشکل بسیار عجیبی دارم کتابخانه inflector در لوکال هاست به خوبی لود میشود ولی در وی.پس.اس اینگونه نیست. این هم کد
کد پی‌اچ‌پی:
                        <?php foreach ($tours as $tour): ?>
                        <li class="liboxs">
                            <?php echo $html->image('B0001WS6L2.jpg', array('url' => array('controller' => 'tours''action' => 'view'$tour['Tour']['id'], Inflector::slug($tour['Tour']['title'], '-')), 'alt' => $tour['Tour']['title'])) ?>
                            <ul>
                                <li class="title"><?php echo $tour['Tour']['title'?></li>
                                <li class="des"><?php echo $tour['Tour']['origin'?> » <?php echo $tour['Tour']['destination'?></li>
                                <li class="day"><?php echo $tour['Tour']['stay_long'?> روز</li>
                                <li class="price"><?php echo $tour['Tour']['price'?> تومان</li>
                            </ul>
                        </li>
                        <?php endforeach ?>
بخش inflector:Confusedlug یه friendly url را از طریق مقدار فیلد title از مدل tour میسازد. کد در لوکال هاست بدین صورت است.
example.com/tour/1/تور-دوبی
ولی در وی.پی.اس example.com/tour/1
پاسخ
سپاس شده توسط


پیام‌های این موضوع
لود نشدن کتابخانه inflector - Arman_gh - 2011/05/23, 12:34 AM

موضوعات مشابه ...
موضوع نویسنده پاسخ بازدید آخرین ارسال
Brick کلاس Inflector : تعریف و کاربرد آن saleh 4 8,098 2017/09/28, 12:30 PM
آخرین ارسال: site2017
  ذخیره اطلاعات عکس آپلود شده توسط ckfinder در دیتابیس و آپلود نشدن فیزیکی! (حل شد) Mehrdad 4 4,888 2016/02/04, 11:27 AM
آخرین ارسال: signcompany1394

پرش به انجمن:


کاربران در حال بازدید این موضوع: 1 مهمان